最終更新:
IPv4とIPv6の違いは?アドレス・暗号化・接続方法を図解
IPv4とIPv6:住所の広さと使い方
43億個もあるなら十分じゃないの?
NATって便利そうだけど、問題もあるの?
外から接続しようとしても、変換の対応付けがなければどの端末に届けるか決められないんだ。ポート転送などで接続できる構成もあるから「絶対につなげない」わけではないよ。また、アドレス変換とファイアウォールによる通信の許可・拒否は別の役割なんだ。
デュアルスタックだと2つの住所を持ってるみたいだけど、どっちを使うか迷わないの?
普通にインターネット使ってる分には、あんまり意識しなくても大丈夫なのかな?
違いを一覧で確認する
| IPv4 | IPv6 |
|---|---|
| 長さ:32ビット | 長さ:128ビット |
| 表記:192.168.1.1 | 表記:2001:db8::1(文書用の例) |
| 共有:家庭のルーター等でNAPTを使う構成がある | 共有:各端末にグローバルアドレスを割り当てる構成がある |
| 暗号化:IPv4であること自体は暗号化を意味しない | 暗号化:IPv6であること自体は暗号化を意味しない |
| 通信:両対応または変換の仕組みが必要 | 通信:両対応または変換の仕組みが必要 |
アドレスの組み合わせ数と、一般の端末へ割り当てられる数は同じではありません。また、IPv6を使えばすべての回線で速くなるとは限りません。日本の回線で見かけるIPv4 over IPv6等の提供方式と、IPv6というプロトコル自体の特徴を分けて確認します。
接続できないときの確認順
- 接続先のサービスがIPv4・IPv6のどちらに対応しているか確認します。
- 回線事業者の契約・提供方式、ルーターの対応と設定を確認します。
- 端末がアドレスを取得できているか、DNSの応答と接続経路を確認します。
- サービスを公開する側なら、両方の経路でファイアウォール等のアクセス制御を確認します。
原因が分からないままファイアウォールを全許可にするのではなく、接続先・回線・端末のどこで届かなくなっているかを切り分けます。まず住所と名前の関係を知りたい場合はDNSの仕組みも参考になります。
参考資料
- RFC 8200 — IPv6 Specification(1節:32ビットから128ビットへの拡張)
- RFC 4291 — IPv6 Addressing Architecture(2.2節:アドレス表記)
- RFC 3022 — Traditional IP Network Address Translator(NAT/NAPT)
- RFC 8504 — IPv6 Node Requirements(13節:IPsec)
- RFC 8305 — Happy Eyeballs Version 2(5節:接続試行)
- RFC 6146 — Stateful NAT64
- RFC 6147 — DNS64